Contents
  1. 1. Input Specification:
  2. 2. Output Specification:
  3. 3. Sample Input:
  4. 4. Sample Output:

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

题目大意:给出三个十进制数,分别将其转化成13进制数字,13进制数字的10,11,12分别由A、B、C表示,不足两位前面补0。先输出#号,在依次输出对应的13进制数字。

分析:将a对应的13进制数(a>=0 && a<=168)的十位数是a/13,个位数是a%13。输出其13进制对应的字符即可。

1
2
3
4
5
6
7
8
9
10
11
12
#include<iostream>
using namespace std;
int main(){
int a;
string dict="0123456789ABC";
cout << "#";
for (int i=0;i<3;i++){
cin >> a;
cout << dict[a/13] << dict[a%13];
}
return 0;
}
Contents
  1. 1. Input Specification:
  2. 2. Output Specification:
  3. 3. Sample Input:
  4. 4. Sample Output: